Welcome to SocialEngine User Community! This is an idea exchange area for SocialEngine users. Ask questions or post your feature requests here. This isn't an official support channel, so if you need support, please open a support ticket

Post Something!

Recent Activity

New Members

Online Now

2 guests

PHP Help

    • 1
    How do I back up my site?
    Where do I find information on backing up my site? I am having issues with my domain name.

    I
    built my site on the .net version but want it to be a .com version and I
    need to back up my site information so I don't lose everything.

    Lora
      • 1
      Donna Hi Lora,

      For future reference to save you time, our documentation is found here, http://support.socialengine.com/php/customer/portal/articles/1686929-socialengine-php-v4-table-of-contents .

      The backup tutorial is here, http://support.socialengine.com/php/customer/en/portal/articles/1641112-making-and-restoring-backups?b_id=14386 , but your host would be a better resource in case they have something else for backing up your site files and database.
    • 1
    ERR_BLOCKED_BY_XSS_AUDITOR - Someone Already Found This Error?
    Today I started to receive a special error in chrome when "posting" in pages that use TinyMCE and here is a explanation about:

    http://www.ryadel.com/en/err_blocked_by_xss_auditor-error-google-chome-fix/

    Seems that Chrome started to block some pages that it consider insecure even that there are no "strange" code as it say in the error description. I already checked and there is no security hole, so I would like to ask if someone is facing this issue also?
      • 1
      SocialEngineAddOns Our developers have worked on this error and come up with a fix for this issue. You can visit this post for the fix: https://www.socialengineaddons.com/content/ERR_BLOCKED_BY_XSS_AUDITOR
      After applying the suggested patch, you will be able to browse your SocialEngine PHP website on Chrome 57 without any error. Hope that helps!
      • 1
      Donna My chrome is updated to Version 58.0.3029.96 (64-bit) and I went to layout editor and added a rich text block and didn't have an issue for that.

      Not sure what you are trying to add to headers so it's harder for me to test.
      • 1
      Donna Which version are you using for SEPHP? I'll go test. Our 4.9 has updated the TinyMCE editor.
    • 4 more comments
    • 1
    Redis vs nginx vs xVarnish; also where is SE official guide to Redis config?
    1.  Can someone please provide a link to SE's official guide on Redis config?  My host needs it.

    2.  (I realize nginx is not officially supported by SE)
    Due
    to moving to PHP7.1 (after SE 4.9.x upgrade of course), I most likely
    will be forced to use Redis.  I guess what I'm trying to find out is if
    I'll be 'okay' or worse off than I am now as far as page load
    performance.

    I'm currently running 4.8.13 with a lot of Plugins
    and the host has nginx configured (pages initially load around 6-7
    secs).  A few months ago I tried xVarnish, and experienced 2 issues: A)
    login and one particular Plugin usually loaded very slowly (3+ minutes);
    B) page load was about the same as nginx but after a while (not sure
    exactly how many minutes) it went slow if that particular page hadn't
    been loaded in a while.  End result - xVarnish was unacceptable.

    Your help/experience would be appreciated.


      • 1
      Gabry Hello, if i understand good and you want to use Redis as a cache feature then i will give you the info on how i did it on my server and work's very good.You need access to SSH with root/pass and input :

      rpm -Uvh http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
      rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
      yum -y --enablerepo=remi,remi-test install redis
      Type redis-server to start the server and sometimes is good to restart VPS
      • 0 1 vote
      • Reply
      • 1
      Mikel Coreclark Hello again, About Redis.
      when I was using another script creator that used redis although it was new I and many other users had problems ( not saying that redis was bad) it just was not working for us and we turned redis off and carried on using the standard nginx. the result of this was a more reliable network with our needs.
      don't get me wrong, redis will work for many people depending on their needs, I will not be using redis for the foreseeable future.
      mikel
      • 1
      Mikel Coreclark Hello. Mikel here.
      I have just been reading the chatter about this. Since I have had the same experience on both matters and here is my insight. Just to let you know,
      I am not an expert and have very little tech knowledge except what I learn from my mistakes or from Donna / Scripttechs / SE / Tmd hosting assistance or other members.

      1, Speed. the more content you have on your server or servers, the more powerful the server needs to be sometimes for large networks or large site with lots of data to transfer a (shared server) may not be the best option. So since you have your script plus 150 added plugins that is a lot of data the server has to monitor and transfer at any given moment to many different devices (i will talk about them later)..

      resolve the issue:
      1, plugins, do not use all t the same time. use about 5 or 6 if possible and the rest you can (TURN ON OR OFF) without deleting, to keep members interest. this will decrease the servers work load and can increase the data transfer speed.

      2, I am hosted on TMD Hosting, I mentioned that my speed was slow roughly 2 to 8 minutes to load depending on my device. I had them transfer me to their cloud server ( as this was better than the standard server ) and my time was greatly reduced and now my transfer time is much like 1 to 5 seconds depending on device used . so that is great.

      3, Devices.
      since 99% of devices ( ipads, cell phones, laptops, desk tops ) used now are basically mini computers they all operate at different speeds with many different programmes and many different internet providers with different levels of speed levels.
      Most people do not keep their devices clean and up to date with the newest updates or the latest ips speeds.
      This means that their devices can be slowing down the (transfer speed) that your site needs to download all your data. So if you think that your site is slow, it most likely be the device and not you.
      I always check my site speed on 3 main devices, galaxy pad, cell phone and desk top, I get an average load speed and use British telecom for my internet provider. So I get a good idea how things are working.

      So basically the speed issue may not be your fault but other users. What I do from time to time when I do updates / upgrades or add new items is to put an announcement on my site to remind members to update their devices as my site may require faster upload / transfer speed.

      I hope this makes sense to you or any other reader.
      Mikel.
    • 14 more comments
    • 1
    Member Browse Menu
    What are the links that should be in the Member browse navigation menu?

    I noticed that in my layout editor that this menu is with the Member Browse page but when I looked at the menu in my navigation that its blank and just shows a blank box on the Member browse page? Does anyone know how this menu should work or what should be included on it?
      • 1
      Donna The only thing that menu has is the breadcrumb. IIRC, a tech had said once it can be edited to add other things but is mainly showing the breadcrumb.
      • 1
      gs I use a Plugin instead but I checked the standard SE stuff and it seems I have the same thing as you. The Member Browse Nav Menu in Menu Editor has no items. In Layout Editor a Member Browse Menu widget exists at the top of the Member Browse Page.

      I don't know the URL of the SE Member Browse and no longer have it in my customized menu structure so I can't actually load that page to see what's displayed in the menu. What options (if any) do you see in your live Member Browse page? It's possible this is hard-coded just like some of the 'content' widgets are, but someone more knowledgeable than me would know that for sure.

      So I may not have been much help other than to say what you are seeing seems to be the way it is (at least for 2 of us).
    • 1
    Customize Chat Colors
    Using: SocialEngine PHP 4.9

    I have changed some of the color schemes on my theme and have been testing my site. I am really pleased with it so far. However, when I access the CHAT and write a test message everything is appearing in white text. This raises an issue for me. 

    Does anyone know how to customize the background color of the chat window from white to another color? 

    I hope someone can help with this issue because if not I will have to redo my entire site or disable the chat plugin and I really dont want to take away this feature. 
      • 1
      Donna I'm not in my site at the moment but did you use inspect element to see the CSS and then change it in the theme.css file? Is this for the IM chat at the bottom of the site or the chat room?
      • 1
      gs ==>"if not I will have to redo my entire site or disable the chat plugin and I really dont want to take away this feature. "

      (I realize this doens't answer your question directly) Another option you may wish to consider (although there's a cost to it) is to use CometChat. This way you won't have to redo your site. They have a host of configuration options for colors/themes/etc. Plus it will remove any chat load from your server setup.
    • 2
    Website Name After Page Description?
    I can be wrong, but I remember that until version 4.8.13 website name was before the page title, but now seems that the opposite is happening.

    In other words instead of sitename - page name description the website is displayed as page name description - sitename. Is this correct?
    • 1
    Where are the Setting from the New Comment and Like System?
    Hello,

    I remember that the new feature that improve the comment and like system has setting to enable it. Where these settings are avaliable? I checked the admincp, but couldnt find in what section they are avaliable

      • 1
      Donna Hi [862,Sieg] ,

      Our documentation is on our knowledgebase but let me link the tutorial for you :)

      http://support.socialengine.com/php/customer/portal/articles/1645717-admin-panel---settings->-activity-feed-settings

      That was updated to show the new settings.
    • 1
    Iframely Options
    Hello,

    I am testing the version 4.9 and I confess that in despite of price to use the iframely api, I could understand the difference between the Social Engine Api and Host a Api. The Social Engine Hosted Api use Iframely or it use the old version from SE?
      • 1
      Donna The SocialEngine Hosted version is the Iframely hosted by SE for licensed clients. :) We did this for clients that might not want to use the paid Iframely or on their own servers. Hope you enjoy it! :)
    • 1
    Redirect to "www" or not ?
    Hello, i have noticed that sometimes the website works different if is
    or not redirected to use www , for example a plugin can give error or
    not working properly if the website is not loading with www.
    What is your opinion about redirect, is good to insert in .htaccess the redirect code and use www.site.com or site.com ?
      • 1
      Eugene It's a good practice to set redirect to non-www version (or to www version). Make sure that only one domain version is actively used. There might be multiple problems if you use both version at the same time, for example, if you logged in www domain you won't have the same session in non-www. And if you set Facebook/Linkedin login they wll threat www and non-www as 2 different websites. That mean there might be issues with redirects after the login.
      • 1
      Donna Good question. I use a redirect to send all to my non-www url. I have google set up to use the non-www as well.

      https://moz.com/learn/seo/duplicate-content

      However, looking at this article, http://www.themezilla.com/should-you-use-www-in-your-url-or-not/ if I want to future proof my sites, I need to change to www as the non-www can mess up caching and static content on active sites.

      Thanks for posting this topic! It will be interesting to see other feedback.
    • 1
    Organize membership type
    To keep my social network professional I am trying to figure out a way to put my membership types in alphabetic order or some type of custom order. When a visitor signs up on my site there is no organization when the pulldown is accessed on signup. Does anyone have advice or know how I can access the file directly? I have experience with coding but unsure where the page or coding is located for this. Furthermore, hopefully the organization will affect membership type on member browse page also.
      • 1
      Brandon Buchanan It seems like everything is wrong with social engine. I've spent more time requesting help and support than building my site. I always get the same answer to request a feature or get an expert. This is getting ridiculous
      • 1
      Donna It looks like you'll need a customization for this or a feature request. You would get it done faster by a customization from an expert, https://www.socialengine.com/experts/category/all . I didn't have a lot of time to experiment but if I find anything when I get more time to dig in the code, I'll post.
      • 1
      Brandon Buchanan Profile types
    • 2 more comments