Social Engine Seems not sending information to Redis

I decided to give a try to redis trying to reduce my page loading time. Everything seems to be working fine, Redis is installed, Social Engine configured to run using Redis, except by the fact that when I look in the Redis Monitor there is no message of information be served by him.

In general when Redis is working if you reload a page, some get command will appear in the redis monitor, but my case I only see "SELECT" "0".

Someone already had any experience with this?

    • 1
    Gabry Hello , before checking with monitor , flush your redis cache redis-cli FLUSHALL ... then command redis-cli MONITOR to see if redis works or not ... for me is working good , i can see activity from website in real time ... remember to close monitor after this as is eating a lot of resources.PS: remember also to start or restart your redis server , maybe is not working that;s way you can;t see anything.
    • 0 1 vote
    • Reply
      • 1
      Sieg Here is how the redis monitor appear to me:

      # redis-cli flushall
      (error) MISCONF Redis is configured to save RDB snapshots, but is currently not able to persist on disk. Commands that may modify the data set are disabled. Please check Redis logs for details about the error.
      # redis-cli monitor
      1499076958.847678 [0] "SELECT" "0"
      1499076960.389291 [0] "SELECT" "0"
      1499076967.286308 [0] "SELECT" "0"
      1499076968.696787 [0] "SELECT" "0"
      1499076975.231367 [0] "SELECT" "0"
      1499076975.656028 [0] "SELECT" "0"
      1499076976.922647 [0] "SELECT" "0"
      1499076978.710378 [0] "SELECT" "0"
      1499076984.500058 [0] "SELECT" "0"
      1499076985.498058 [0] "SELECT" "0"
      1499076986.759537 [0] "SELECT" "0"
      1499076988.549986 [0] "SELECT" "0"
      1499076989.796682 [0] "SELECT" "0"
      1499076995.039938 [0] "SELECT" "0"
      1499076999.640180 [0] "SELECT" "0"
      1499077005.237256 [0] "SELECT" "0"
      1499077013.560553 [0] "SELECT" "0"
      1499077014.272841 [0] "SELECT" "0"
      1499077015.641608 [0] "SELECT" "0"
      1499077017.220548 [0] "SELECT" "0"
      1499077018.272043 [0] "SELECT" "0"
      1499077026.040754 [0] "SELECT" "0"
      1499077027.542770 [0] "SELECT" "0"
      1499077028.066139 [0] "SELECT" "0"
      1499077032.109966 [0] "SELECT" "0"
      1499077033.018220 [0] "SELECT" "0"
      1499077049.087035 [0] "SELECT" "0"
      1499077050.374675 [0] "SELECT" "0"
      1499077060.767929 [0] "SELECT" "0"
      1499077068.058708 [0] "SELECT" "0"
      1499077097.962047 [0] "SELECT" "0"
      1499077098.751455 [0] "SELECT" "0"
      1499077115.605177 [0] "SELECT" "0"
      1499077117.132962 [0] "SELECT" "0"
      1499077118.014249 [0] "SELECT" "0"
      [1]+ Stopped redis-cli monitor

      I will restart the server once the amazon s3 files tranfer finishes. I tried to restart only the service, but no command that I found worked.
        • 1
        Gabry I seems that redis server is not working good ... i am not that able to give advice on how to fix it from this point but try to install it again using next method , maybe works without any errors ... this is how i install it and is working :

        rpm -Uvh
        rpm -Uvh
        yum -y --enablerepo=remi,remi-test install redis

        After finish installing type redis-server for start redis server ...if is not starting check if the server blocks port 6379 ...that's all ... exit from console , is good also to restart your VPS and then check again if works .. about restarting that not works for you is because the redis is not configured good so it can't start restart until the issues are fixed.
        • 0 1 vote
        • Reply
          • 1
          gs My host informed me that Redis isn't fully updated for use with PHP7.* (I have no idea if this is true or not). Also, SE paid support has refused to configure it on my server, and also still does not provide official documentation for a Host to follow (and although the link you've provided Gabry may be helpful, my Host won't bother with anything unofficial as they are looking for accountability with software developers (SE in this case). I'm tired of hearing about 'your host has to tweak it to work with SE' with 'it' referring to whatever is being asked about. I believe in 'this is how to make it work, and if you do this and it doesn't work, we'll have your back and fix it'. This seems to not be the case with SE :(
            • 1
            Gabry Well, usually the host teams don't like too much clients that want's to install to many extra-things on their server because they want to save resources , that's way they find a lot of reasons not to help you or tell you that is not possible for the moment to install something because of a reason...this way they can also respect what you see on many hosting companies and that is 99 up-time...that's way i bought a self-manage VPS so i can do what i want on my own risk ...for example installing something depends a lot also on the architecture of the OS on your server , if you use or not a good CP like Cpanel and what other plugins you have installed and ports used ... i personally tried at least 8 tutorials on installing Redis ... 7 of them failed even if i respected perfect the steps... and the last tutorial that i also put in here worked perfect .. that;s way i will give it to everybody to use it even if i don;t know if it will work or not for them but for me is working good so i hope i can help other people.
            • 0 1 vote